Your site is running on Wordpress 3.3.1. Travel Blogger Theme requires at least Wordpress 3.7. Please consider upgrading WordPress, it's safer, faster and carries more features.